Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/openssl/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 09:50:13 +0100
committerErich Eckner <git@eckner.net>2019-01-21 09:50:13 +0100
commit64dab5e626f0eff2cc7760c018bfbf836f1c9321 (patch)
tree23b68838d97bc433d1742c9aa6fc1c47667ff984 /core/openssl/PKGBUILD
parent190caffff9a5355a9a31872b800d75bab0fa31ea (diff)
parent7d1da76a8b1031b042e634df60c909c713c423d7 (diff)
Merge branch 'master' into i486
Diffstat (limited to 'core/openssl/PKGBUILD')
-rw-r--r--core/openssl/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
index e3e0d088..4446cbc6 100644
--- a/core/openssl/PKGBUILD
+++ b/core/openssl/PKGBUILD
@@ -1,11 +1,17 @@
-# i486-specific
+# switch to 32-bit target (was linux-elf before, which I think is wrong also for i686)
+eval "$(
+ declare -f build | \
+ sed '
+ s@linux-x86_64@linux-generic32@
+ '
+)"
+
+# i486-specific, disable hand-crafted assembly code
if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
s@no-ssl3-method@no-ssl3-method no-ssl2 no-ssl3@
- s@'i686'@'i486'@
- s@'linux-elf'@'linux-generic32'@
'
)"
fi