Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/squid/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:08:05 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:08:05 +0100
commit149f379709d64b238fa46b48a3ef88816f1bc8a1 (patch)
treee242c726fc402d0ba90f4930fcbeaa3169bda49f /community/squid/PKGBUILD
parent1897f7c02af5ed11fa4c47c1a8de9f214dbdbd8c (diff)
parentc980d934f2ffb085002debe9e4c863b5e5f48934 (diff)
Merge branch 'master' into i486
Diffstat (limited to 'community/squid/PKGBUILD')
-rw-r--r--community/squid/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/squid/PKGBUILD b/community/squid/PKGBUILD
new file mode 100644
index 00000000..1a2bcc45
--- /dev/null
+++ b/community/squid/PKGBUILD
@@ -0,0 +1,13 @@
+# testing libatomic for __atomic_load_8 fails in configure.ac, following the idea in
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=830942
+# TODO: report upstream in squid project
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|make|make LDFLAGS="-Wl,--as-needed -latomic -Wl,--no-as-needed"|g
+ ';
+ )"
+fi