Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/libnids
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /community/libnids
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'community/libnids')
-rw-r--r--community/libnids/PKGBUILD17
-rw-r--r--community/libnids/libnids-1.24-inline.patch46
2 files changed, 0 insertions, 63 deletions
diff --git a/community/libnids/PKGBUILD b/community/libnids/PKGBUILD
deleted file mode 100644
index 7a510454..00000000
--- a/community/libnids/PKGBUILD
+++ /dev/null
@@ -1,17 +0,0 @@
-# libndis defines some functions inline, so they are not in the shared library,
-# needed for instance for dsniff
-# see https://src.fedoraproject.org/cgit/rpms/libnids.git/commit/?id=ecafb692f20e0acad555f66c3cc1646997a82dae
-
-source+=('libnids-1.24-inline.patch')
-sha256sums+=('3aea2351877c2a789d753ac66f1323a3d575dead9fb04c559e221dbebdfc7e3e')
-
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname-$pkgver" \
- patch -Np1 -i "$srcdir/libnids-1.24-inline.patch"
- '
-)"
diff --git a/community/libnids/libnids-1.24-inline.patch b/community/libnids/libnids-1.24-inline.patch
deleted file mode 100644
index b17b73e9..00000000
--- a/community/libnids/libnids-1.24-inline.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -rauN libnids-1.24/src/checksum.c libnids-1.24-inline-patch/src/checksum.c
---- libnids-1.24/src/checksum.c 2010-02-26 11:58:41.000000000 +0100
-+++ libnids-1.24-inline-patch/src/checksum.c 2018-05-03 07:53:10.552320792 +0200
-@@ -120,7 +120,7 @@
- By Jorge Cwik <jorge@laser.satlink.net>, adapted for linux by Arnt
- Gulbrandsen.
- */
--inline u_short ip_fast_csum(u_char * iph, u_int ihl)
-+u_short ip_fast_csum(u_char * iph, u_int ihl)
- {
- u_int sum;
- if (dontchksum(((struct ip*)iph)->ip_src.s_addr))
-@@ -172,7 +172,7 @@
- computes the checksum of the TCP/UDP pseudo-header
- returns a 16-bit checksum, already complemented
- */
--static inline u_short
-+static u_short
- csum_tcpudp_magic(u_int saddr, u_int daddr, u_short len,
- u_short proto, u_int sum)
- {
-@@ -191,13 +191,13 @@
- this routine is used for miscellaneous IP-like checksums, mainly in
- icmp.c
- */
--inline u_short
-+u_short
- ip_compute_csum(u_char * buff, int len)
- {
- return (csum_fold(csum_partial(buff, len, 0)));
- }
-
--inline u_short
-+u_short
- my_tcp_check(struct tcphdr *th, int len, u_int saddr, u_int daddr)
- {
- if (dontchksum(saddr))
-@@ -205,7 +205,7 @@
- return csum_tcpudp_magic(saddr, daddr, len, IPPROTO_TCP,
- csum_partial((u_char *)th, len, 0));
- }
--inline u_short
-+u_short
- my_udp_check(void *u, int len, u_int saddr, u_int daddr)
- {
- if (dontchksum(saddr))