Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/hq
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:55 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:55 +0100
commitb1ef18278ba295fcddd30751d8294e76e638724e (patch)
treec04e42280fe27b7c73195b0cba36b73faae44400 /community/hq
parent70a7c30b8196a4398cf755b93507516d0f83be56 (diff)
parent665c195f3812e8a410095ac2ffa5a692116870e2 (diff)
Merge branch 'master' into i486
Diffstat (limited to 'community/hq')
-rw-r--r--community/hq/PKGBUILD7
-rw-r--r--community/hq/hq-ia32.patch12
2 files changed, 19 insertions, 0 deletions
diff --git a/community/hq/PKGBUILD b/community/hq/PKGBUILD
new file mode 100644
index 00000000..4e22d247
--- /dev/null
+++ b/community/hq/PKGBUILD
@@ -0,0 +1,7 @@
+# see upstream https://github.com/coderobe/hq/pull/1
+source+=('hq-ia32.patch')
+md5sums+=('3cecc7f3b1bbe96f6c3a1609730ba574')
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i ../hq-ia32.patch
+}
diff --git a/community/hq/hq-ia32.patch b/community/hq/hq-ia32.patch
new file mode 100644
index 00000000..07a924e0
--- /dev/null
+++ b/community/hq/hq-ia32.patch
@@ -0,0 +1,12 @@
+diff -rauN hq/main.cpp hq-ia32-patch/main.cpp
+--- hq/main.cpp 2018-11-25 17:00:49.731669567 +0100
++++ hq-ia32-patch/main.cpp 2018-11-25 17:01:32.498826389 +0100
+@@ -51,7 +51,7 @@
+ static const string afmt_s = "\033[";
+ static const string afmt_e = "m";
+ static const vector<char> collapsible = {' ', '\t', '\n', '\r'};
+-static const vector<unsigned long> breaking = {
++static const vector<myhtml_tag_id_t> breaking = {
+ MyHTML_TAG_BR,
+ MyHTML_TAG_P
+ };