Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 11:04:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 11:04:21 +0200
commit8beb185e284d319393fe5a29e59b74f5321d2a05 (patch)
treed67919cd35d35ff4d3cfc41e896279fcc825dfa5 /build-support
parent4c6f76d856f9787a44e308b7faf3e4ccefcb56be (diff)
added python-build-boostrap to build-support
Diffstat (limited to 'build-support')
-rw-r--r--build-support/python-build-boostrap/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/build-support/python-build-boostrap/PKGBUILD b/build-support/python-build-boostrap/PKGBUILD
new file mode 100644
index 00000000..892ce420
--- /dev/null
+++ b/build-support/python-build-boostrap/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+_pkgname=build
+pkgname=python-$_pkgname
+pkgver=0.10.0
+pkgrel=4
+pkgdesc='A simple, correct PEP 517 build frontend'
+arch=('any')
+url='https://github.com/pypa/build'
+license=('MIT')
+makedepends=('git' 'python-pip-bootstrap')
+checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-rerunfailures' 'python-filelock' 'python-setuptools' 'python-toml' 'python-wheel')
+source=("git+$url#tag=$pkgver?signed")
+validpgpkeys=('3DCE51D60930EBA47858BA4146F633CBB0EB4BF2') # Filipe Laíns (FFY00) <lains@archlinux.org>
+sha512sums=('SKIP')
+
+build() {
+ cd $_pkgname
+
+ # we install build, installer with pip to break the cycle
+ pip install build
+ pip install installer
+ pip install flit_core
+
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd $_pkgname
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}