Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/muon-meson/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-22 12:07:49 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-22 12:07:49 +0100
commit0548e420f40ca29a2c2f746407f7637488082959 (patch)
treead21243ec897ae980b2926948c3e23497acb9ba4 /build-support/muon-meson/PKGBUILD
parent599ccf759fff362d6da25e5e8ce8c3b6cf3d1a39 (diff)
build-support/muon-meson: updated to 0.5.0
Diffstat (limited to 'build-support/muon-meson/PKGBUILD')
-rw-r--r--build-support/muon-meson/PKGBUILD51
1 files changed, 32 insertions, 19 deletions
diff --git a/build-support/muon-meson/PKGBUILD b/build-support/muon-meson/PKGBUILD
index 6eb8ba82..0be5f4f8 100644
--- a/build-support/muon-meson/PKGBUILD
+++ b/build-support/muon-meson/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=muon-meson
-pkgver=0.3.1
-pkgrel=3
+pkgver=0.5.0
+pkgrel=1
pkgdesc="meson implementation in C"
arch=(x86_64 pentium4 i686 i486)
url="https://muon.build"
@@ -10,7 +10,7 @@ license=(GPL3)
source=(
"$url/releases/v$pkgver/muon-v$pkgver.tar.gz"
"arch-muon")
-sha256sums=('45f6ad728946a0788188004e3a88a77a7d07b48525ce0646430589d1db4c832e'
+sha256sums=('d657422d4a102b4c7b77317a67a3f816d02f1c2967432b027c7e9f076ffe7079'
'4e507d5b129cd7de05aca972504ab06c2353b145e7378d15aa75b7d4b1b252e8')
#depends=(pkgconf curl libarchive)
depends=(pkgconf)
@@ -27,30 +27,48 @@ build() {
./bootstrap.sh build-stage1
msg2 "Building stage 2 (muon from bootstrap)"
- build-stage1/muon setup \
- -D docs=disabled \
- -D libpkgconf=enabled \
- -D libcurl=disabled \
+ build-stage1/muon-bootstrap setup \
-D libarchive=disabled \
+ -D libcurl=disabled \
+ -D libpkgconf=enabled \
+ -D man-pages=disabled \
+ -D meson-docs=disabled \
+ -D meson-tests=disabled \
+ -D readline=builtin \
+ -D samurai=enabled \
+ -D static=false \
+ -D tracy=disabled \
+ -D ui=disabled \
+ -D website=disabled \
build-stage2
ninja -C build-stage2
msg2 "Building stage 3 (muon from muon)"
build-stage2/muon setup \
- -D prefix=/usr \
- -D b_lto=false \
- -D b_pie=false \
- -D docs=disabled \
- -D libpkgconf=enabled \
- -D libcurl=disabled \
-D libarchive=disabled \
+ -D libcurl=disabled \
+ -D libpkgconf=enabled \
+ -D man-pages=disabled \
+ -D meson-docs=disabled \
+ -D readline=builtin \
+ -D samurai=enabled \
+ -D static=false \
+ -D tracy=disabled \
+ -D ui=disabled \
+ -D website=disabled \
+ -D prefix=/usr \
+ -D b_lto=true \
+ -D b_pie=true \
build
ninja -C build
}
check() {
+ # Explicitly chose which test suites to run, to avoid running meson-tests
+ # and taking a long time to run, but still having a reasonable coverage
+ # to ensure that the built package works.
cd "muon-v$pkgver/build"
- ./muon test || true
+ ./muon test -R -v -s fmt -s lang -s muon -s unit -s analyze
}
package() {
@@ -58,9 +76,4 @@ package() {
DESTDIR="$pkgdir" ./muon install
install -Dm775 "$srcdir/arch-muon" "$pkgdir/usr/bin/arch-muon"
-
- # remove this as the `meson` package also provides it
- # muon only has a `docs` option right now, so
- # downloading/generating/deleting is the only option :/
-# rm "$pkgdir"/usr/share/man/man3/meson-reference.3
}