Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-25 15:17:04 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-25 15:17:04 +0200
commit79d317802c0ea3374658609e9300770bab961b25 (patch)
tree43cf8aa7f2c97dd95c3208a10875ef947d0c4138
parent73886651b79919f47a2467defc077b7ab9e0af47 (diff)
community/julia: another try to build julia
-rw-r--r--blacklist/pentium4/julia/julia1
-rw-r--r--community/julia/PKGBUILD28
2 files changed, 21 insertions, 8 deletions
diff --git a/blacklist/pentium4/julia/julia b/blacklist/pentium4/julia/julia
deleted file mode 100644
index e40938fb..00000000
--- a/blacklist/pentium4/julia/julia
+++ /dev/null
@@ -1 +0,0 @@
-/build/julia/src/julia/src/atomics.h:9:4: error: #error Julia can only be built for architectures above Pentium 4. Pass -march=pentium4, or set MARCH=pentium4 and ensure that -march is not passed separately with an older architecture.
diff --git a/community/julia/PKGBUILD b/community/julia/PKGBUILD
index e8de39ab..a00df5b2 100644
--- a/community/julia/PKGBUILD
+++ b/community/julia/PKGBUILD
@@ -1,17 +1,31 @@
eval "$(
declare -f build | \
sed '
- /^\s*make / i CFLAGS+=" -march=pentium4" \
- CXXFLAGS+=" -march=pentium4"
- /MARCH="/ s/"x86-64"/"pentium4"/
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
'
)"
eval "$(
- declare -f package_julia | \
+ declare -f package | \
sed '
- /^\s*make / i CFLAGS+=" -march=pentium4" \
- CXXFLAGS+=" -march=pentium4"
- /MARCH="/ s/"x86-64"/"pentium4"/
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
'
)"