Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2022-05-02 18:45:55 +0200
committerErich Eckner <git@eckner.net>2022-05-02 22:05:36 +0200
commit382516c684e248dd8bddc47f0e673a07ccecf992 (patch)
treebf3ea5a55095637fd2dc964d5ddb8381770d48da
parentce243416e4ceda5325d56bfbc872d06d6b56e5a1 (diff)
Revert "extra/firefox: disabled archive-server"
This reverts commit a68c68ebd7e208aea68a9e140d115fddacc23168.
-rw-r--r--extra/firefox/PKGBUILD114
1 files changed, 57 insertions, 57 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 238a82fd..329e0b96 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -49,63 +49,63 @@ eval "$(
# use locally cached version of firefox sources
# TODO: think about how to put this into helper functions
-#~ for ((i=0; i<${#source[@]}; i++)); do
- #~ infos=$(
- #~ printf '%s\n' "${source[${i}]}" | \
- #~ sed -n '
- #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^?#]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- #~ T
- #~ p
- #~ '
- #~ )
- #~ if [ -n "${infos}" ]; then
- #~ source[${i}]=$(
- #~ type="${infos%% *}"
- #~ infos="${infos#* }"
- #~ if [ -n "${infos%% *}" ]; then
- #~ prefix="${infos%% *}"
- #~ else
- #~ prefix=''
- #~ fi
- #~ infos="${infos#* }"
- #~ repo="${infos%% *}"
- #~ repo64=$(
- #~ printf '%s' "${repo}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
- #~ infos="${infos#* }"
- #~ if [ "${infos%% *}" = '?signed' ]; then
- #~ key_check=$(
- #~ printf '&valid_keys='
- #~ printf '%s,' "${validpgpkeys[@]}" | \
- #~ sed 's/,$//'
- #~ )
- #~ else
- #~ key_check=''
- #~ fi
- #~ infos="${infos#* }"
- #~ if [ -z "${prefix}" ]; then
- #~ prefix="${repo%.git}"
- #~ prefix="${prefix##*/}"
- #~ fi
- #~ prefix_64=$(
- #~ printf '%s/' "${prefix}" | \
- #~ base64 -w0 | \
- #~ sed 's/=/%3D/g'
- #~ )
-
- #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- #~ "${prefix}" \
- #~ "${pkgver}" \
- #~ "${type}" \
- #~ "${prefix_64}" \
- #~ "${repo64}" \
- #~ "${key_check}" \
- #~ "${infos}"
- #~ )
- #~ fi
-#~ done
+for ((i=0; i<${#source[@]}; i++)); do
+ infos=$(
+ printf '%s\n' "${source[${i}]}" | \
+ sed -n '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^?#]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
+ T
+ p
+ '
+ )
+ if [ -n "${infos}" ]; then
+ source[${i}]=$(
+ type="${infos%% *}"
+ infos="${infos#* }"
+ if [ -n "${infos%% *}" ]; then
+ prefix="${infos%% *}"
+ else
+ prefix=''
+ fi
+ infos="${infos#* }"
+ repo="${infos%% *}"
+ repo64=$(
+ printf '%s' "${repo}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+ infos="${infos#* }"
+ if [ "${infos%% *}" = '?signed' ]; then
+ key_check=$(
+ printf '&valid_keys='
+ printf '%s,' "${validpgpkeys[@]}" | \
+ sed 's/,$//'
+ )
+ else
+ key_check=''
+ fi
+ infos="${infos#* }"
+ if [ -z "${prefix}" ]; then
+ prefix="${repo%.git}"
+ prefix="${prefix##*/}"
+ fi
+ prefix_64=$(
+ printf '%s/' "${prefix}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+
+ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ "${prefix}" \
+ "${pkgver}" \
+ "${type}" \
+ "${prefix_64}" \
+ "${repo64}" \
+ "${key_check}" \
+ "${infos}"
+ )
+ fi
+done
# from VoidLinux, avoid excessive debug symbols in rust leading
# to out-of-memory situations