Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-11-05 08:12:34 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-11-05 08:12:34 +0100
commit0e71da6e411f24a15cb6c6bf55b605556ff19861 (patch)
treea4712b854f253fa2f984cffa8e3c66f7f685de8e
parent9a6962c7a08569afe55b0216d24aee07380e68a2 (diff)
extra/chezmoi: tried to fix (gcc-go), rebuilding for pentium4 only
-rw-r--r--blacklist/i686/go/chezmoi1
-rw-r--r--blacklist/i686/go/go1
-rw-r--r--community/chezmoi/PKGBUILD8
3 files changed, 10 insertions, 0 deletions
diff --git a/blacklist/i686/go/chezmoi b/blacklist/i686/go/chezmoi
new file mode 100644
index 00000000..cf54652e
--- /dev/null
+++ b/blacklist/i686/go/chezmoi
@@ -0,0 +1 @@
+Doesn't build on i686/i486 with gc, doens't build at all with gcc-go
diff --git a/blacklist/i686/go/go b/blacklist/i686/go/go
new file mode 100644
index 00000000..b6449ddf
--- /dev/null
+++ b/blacklist/i686/go/go
@@ -0,0 +1 @@
+Go dropped FPU/MMX math support, requires SSE2
diff --git a/community/chezmoi/PKGBUILD b/community/chezmoi/PKGBUILD
new file mode 100644
index 00000000..6dac406f
--- /dev/null
+++ b/community/chezmoi/PKGBUILD
@@ -0,0 +1,8 @@
+# Use gccgo and not go/gc on i686 and i486
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//go/})
+ makedepends+=(gcc-go)
+fi
+
+# failing test: FAIL github.com/twpayne/chezmoi/v2/pkg/git [build failed]
+unset check