Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 19:38:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 19:38:59 +0200
commit310bf41e9fb6e7b97cbdb4896a38e712a674c7dc (patch)
tree21c5397c356df9886bb76d61bcb4423c0fc0ce07
parent391d388bb4638ce1bec8e85f8ea733f62beccfd2 (diff)
community/ruby-etc: bootstrapping
-rw-r--r--community/ruby-etc/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-etc/PKGBUILD b/community/ruby-etc/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-etc/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+