Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-05-03 13:50:43 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-05-03 13:50:43 +0200
commitec111e964321eb6f8d56fab22bed0f58e1de1def (patch)
treeb11e6f7a773920fcfc25b7f852e6f22e7e608fc6
parentcf37eb11f81d1c0604cead05b0aa183372f05534 (diff)
core/file: no lseek64
-rw-r--r--core/file/PKGBUILD2
-rw-r--r--core/file/file-5.33-seccomp-32bit.patch7
2 files changed, 4 insertions, 5 deletions
diff --git a/core/file/PKGBUILD b/core/file/PKGBUILD
index f0ff50ee..ab132fd5 100644
--- a/core/file/PKGBUILD
+++ b/core/file/PKGBUILD
@@ -2,4 +2,4 @@
# systems (e.g. fstat64)
source+=('file-5.33-seccomp-32bit.patch')
-md5sums+=('472f29fefe0f60607eae814ff163e551')
+md5sums+=('5e0c3072ad745b55c8560425e6bb904c')
diff --git a/core/file/file-5.33-seccomp-32bit.patch b/core/file/file-5.33-seccomp-32bit.patch
index 63fa936a..27987266 100644
--- a/core/file/file-5.33-seccomp-32bit.patch
+++ b/core/file/file-5.33-seccomp-32bit.patch
@@ -1,7 +1,7 @@
diff -rauN file-5.33/src/seccomp.c file-5.33-seccomp-32bit-patch/src/seccomp.c
--- file-5.33/src/seccomp.c 2017-11-04 02:14:25.000000000 +0100
-+++ file-5.33-seccomp-32bit-patch/src/seccomp.c 2018-05-03 13:38:38.073165287 +0200
-@@ -168,13 +168,19 @@
++++ file-5.33-seccomp-32bit-patch/src/seccomp.c 2018-05-03 13:49:51.826498606 +0200
+@@ -168,13 +168,18 @@
ALLOW_RULE(dup2);
ALLOW_RULE(exit);
ALLOW_RULE(exit_group);
@@ -14,7 +14,6 @@ diff -rauN file-5.33/src/seccomp.c file-5.33-seccomp-32bit-patch/src/seccomp.c
+ ALLOW_RULE(getdents64);
ALLOW_RULE(ioctl);
ALLOW_RULE(lseek);
-+ ALLOW_RULE(lseek64);
ALLOW_RULE(lstat);
+ ALLOW_RULE(lstat64);
ALLOW_RULE(mmap);
@@ -22,7 +21,7 @@ diff -rauN file-5.33/src/seccomp.c file-5.33-seccomp-32bit-patch/src/seccomp.c
ALLOW_RULE(mprotect);
ALLOW_RULE(mremap);
ALLOW_RULE(munmap);
-@@ -188,6 +194,7 @@
+@@ -188,6 +193,7 @@
ALLOW_RULE(rt_sigreturn);
ALLOW_RULE(select);
ALLOW_RULE(stat);