Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-09-09 07:27:18 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-09-09 07:27:18 +0000
commitbfa2db7ade84ab233e71e793a103c2d13dac8ed3 (patch)
tree78570252c3afb50546b5ea4bba87a9c8869bf5fb
parent0e5961e6e0038b2d338c1ecea8db71f1155276ac (diff)
parent43d8fdd33906541c80c7f838a26e0e594a11886a (diff)
Merge branch 'master' into i486
-rw-r--r--blacklist2
-rw-r--r--community/buildah/PKGBUILD8
-rw-r--r--community/dart/PKGBUILD3
-rw-r--r--community/deepin-qt5integration/PKGBUILD2
-rw-r--r--community/electron/PKGBUILD3
-rw-r--r--community/firefox-developer-edition/PKGBUILD6
-rw-r--r--community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch30
-rw-r--r--community/grumpy/PKGBUILD18
-rw-r--r--community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch26
-rw-r--r--community/heaptrack/49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch25
-rw-r--r--community/heaptrack/76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch16
-rw-r--r--community/heaptrack/PKGBUILD15
-rw-r--r--community/heaptrack/c456f6a1575fb2834238a1f693e7c7787d768d42.patch13
-rw-r--r--community/python-faker/PKGBUILD15
-rw-r--r--community/python-faker/remove-century-tests.patch38
-rw-r--r--community/vtk/PKGBUILD2
-rw-r--r--core/linux/PKGBUILD6
-rw-r--r--core/linux/config9
-rw-r--r--core/nss/PKGBUILD3
-rw-r--r--extra/firefox/PKGBUILD6
-rw-r--r--extra/linux-pae/PKGBUILD8
-rw-r--r--extra/linux-pae/config7
-rw-r--r--extra/linux-zen/PKGBUILD7
-rw-r--r--extra/linux-zen/config13
-rw-r--r--extra/thunderbird/PKGBUILD6
-rw-r--r--extra/vulkan-lunarg-tools/PKGBUILD6
26 files changed, 221 insertions, 72 deletions
diff --git a/blacklist b/blacklist
index 1b98bf5d..12f85848 100644
--- a/blacklist
+++ b/blacklist
@@ -24,6 +24,8 @@ i686 parity # "32-bit targets are not supported at the moment, You can use '32bi
i686 python-openstacksdk # infinite looping on build slaves, might be temporary
i686 python-pytorch # Gloo can only be built on 64-bit systems
i686 qcef # contains CEF binaries (not current ones) for 64-bit and MIPS only, no 32-bit Intel. Discuss with the authors if you need it.
+i686 riscv64-linux-gnu-gcc # needs manual bootstrap - is it worth the effort?
+i686 riscv64-linux-gnu-glibc # see riscv64-linux-gnu-gcc
i686 rubinius # Support for non-64bit platforms was deprecated 1 Jun 2016 and has now been removed. If non-64bit support is a critical feature for your application, please email contact@rubinius.com
i686 sbcl # blocks again
i686 skia-sharp # does not provide a bin/gn for 32-bit Linux, see FS32#8
diff --git a/community/buildah/PKGBUILD b/community/buildah/PKGBUILD
new file mode 100644
index 00000000..4fa61167
--- /dev/null
+++ b/community/buildah/PKGBUILD
@@ -0,0 +1,8 @@
+# see https://github.com/projectatomic/buildah/issues/990
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /}/ i find $srcdir -type f -exec sed -i "s/4294967295/2147483647/g" {} \\;
+ '
+)"
diff --git a/community/dart/PKGBUILD b/community/dart/PKGBUILD
index 719d8221..88e30efe 100644
--- a/community/dart/PKGBUILD
+++ b/community/dart/PKGBUILD
@@ -1 +1,2 @@
-sha512sums_i686=('f26e4442b425893dea5fc0a8ca8f8dd014c6a0685bb5da725f3624520e58b589fec3bed909d19ce48298cb3340bc3b7521398e3037a43386935cd69f4a8d70bd')
+source=("$pkgname-$pkgver-32.zip::http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/dartsdk-linux-ia32-release.zip")
+sha512sums=('7e2ba689f4e222d545720c34f0581df5b4e64f39eaf71e3af294ce20869652d71981ae5e95153fe87e049e1fbf8375870209b3b6eae2da8688b75a80f255033b')
diff --git a/community/deepin-qt5integration/PKGBUILD b/community/deepin-qt5integration/PKGBUILD
new file mode 100644
index 00000000..aed3415d
--- /dev/null
+++ b/community/deepin-qt5integration/PKGBUILD
@@ -0,0 +1,2 @@
+# trying to break dependency cycle
+makedepends=(${makedepends[@]/deepin-file-manager})
diff --git a/community/electron/PKGBUILD b/community/electron/PKGBUILD
index b8b43791..395d76f9 100644
--- a/community/electron/PKGBUILD
+++ b/community/electron/PKGBUILD
@@ -4,8 +4,9 @@ sha512sums+=('bce6716f88c0ed7acc72f90ef62f7c4a28b88e98d7fc8dcb6abf545eb6ab7de11e
eval "$(
declare -f prepare | \
sed '
- 2 a find "${srcdir}" \\( '"-name '*.a' -o -name '*.o'"' \\) -delete
3 a patch -Np1 -i "${srcdir}"/allow-i686.patch
+ /^}$/ i \
+ find "${srcdir}" \\( '"-name '*.a' -o -name '*.o'"' \\) -delete
'
declare -f build | \
sed '
diff --git a/community/firefox-developer-edition/PKGBUILD b/community/firefox-developer-edition/PKGBUILD
new file mode 100644
index 00000000..8eba80f3
--- /dev/null
+++ b/community/firefox-developer-edition/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export LDFLAGS+=" -Wl,--no-keep-memory"
+ '
+)"
diff --git a/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch b/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch
new file mode 100644
index 00000000..ffe0f2ed
--- /dev/null
+++ b/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch
@@ -0,0 +1,30 @@
+From 4f3cc3ed446170a161cf8ecb644a740ac233b005 Mon Sep 17 00:00:00 2001
+From: Alan Justino <alan.justino@yahoo.com.br>
+Date: Wed, 7 Mar 2018 19:30:45 -0300
+Subject: [PATCH] Fix int underflow on 32bit CPUs
+
+---
+ tools/pkgc.go | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/tools/pkgc.go b/tools/pkgc.go
+index e04017c7..93a6fe7d 100644
+--- a/tools/pkgc.go
++++ b/tools/pkgc.go
+@@ -75,6 +75,16 @@ func getConst(name string, v constant.Value) string {
+ } else {
+ format = "float64(%s)"
+ }
++ } else {
++ if i, exact := constant.Int64Val(v); exact {
++ if i > math.MinInt8 {
++ format = "int(%s)"
++ } else if i > math.MinInt32 {
++ format = "int32(%s)"
++ } else {
++ format = "int64(%s)"
++ }
++ }
+ }
+ case constant.Float:
+ format = "float64(%s)"
diff --git a/community/grumpy/PKGBUILD b/community/grumpy/PKGBUILD
new file mode 100644
index 00000000..9f331e83
--- /dev/null
+++ b/community/grumpy/PKGBUILD
@@ -0,0 +1,18 @@
+source+=(
+ '4f3cc3ed446170a161cf8ecb644a740ac233b005.patch'
+ 'ef4791393db1ab586400d326ae7d7993e5610d00.patch'
+)
+unset md5sums
+sha512sums=(
+ 'SKIP'
+ 'e86c54bd4bc3492eae0b1cf69a5ea717130024bc6088e994a9a0fae040fdc6962bbbd50cfa4a66b6db228360dd32c0318003f2248f0e41443b60990c67ebcf50'
+ 'f646c59e2b1cab40f67c0e150d33bae55bf8d01142c2e6f7d52c331909c5ecbfcd004b4aaafefb07cea268f9dd1c406c4da77e18453097fc0e3f11467b9a39c8'
+)
+eval "$(
+ declare -f prepare | \
+ sed '
+ 2 a cd "$srcdir/grumpy" \
+ patch -p1 -i "$srcdir/ef4791393db1ab586400d326ae7d7993e5610d00.patch" \
+ patch -p1 -i "$srcdir/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch"
+ '
+)"
diff --git a/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch b/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch
new file mode 100644
index 00000000..c8894732
--- /dev/null
+++ b/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch
@@ -0,0 +1,26 @@
+From ef4791393db1ab586400d326ae7d7993e5610d00 Mon Sep 17 00:00:00 2001
+From: Alan Justino <alan.justino@yahoo.com.br>
+Date: Wed, 7 Mar 2018 19:00:29 -0300
+Subject: [PATCH] Fix overflow on math.MaxInt64
+
+---
+ tools/pkgc.go | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tools/pkgc.go b/tools/pkgc.go
+index 4b08aac5..e04017c7 100644
+--- a/tools/pkgc.go
++++ b/tools/pkgc.go
+@@ -65,7 +65,11 @@ func getConst(name string, v constant.Value) string {
+ case constant.Int:
+ if constant.Sign(v) >= 0 {
+ if i, exact := constant.Uint64Val(v); exact {
+- if i > math.MaxInt64 {
++ if i < math.MaxInt8 {
++ format = "uint(%s)"
++ } else if i < math.MaxInt32 {
++ format = "uint32(%s)"
++ } else {
+ format = "uint64(%s)"
+ }
+ } else {
diff --git a/community/heaptrack/49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch b/community/heaptrack/49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch
new file mode 100644
index 00000000..9ddad81e
--- /dev/null
+++ b/community/heaptrack/49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch
@@ -0,0 +1,25 @@
+diff --git a/tests/auto/tst_io.cpp b/tests/auto/tst_io.cpp
+index 48abda6..fd31b31 100644
+--- a/tests/auto/tst_io.cpp
++++ b/tests/auto/tst_io.cpp
+@@ -27,6 +27,11 @@
+
+ using namespace std;
+
++constexpr uint64_t operator""_u64(unsigned long long v)
++{
++ return static_cast<uint64_t>(v);
++}
++
+ TEST_CASE ("write data", "[write]") {
+ TempFile file;
+ REQUIRE(file.open());
+@@ -124,7 +129,7 @@ TEST_CASE ("read line 64bit", "[read]") {
+ REQUIRE(reader >> module);
+ REQUIRE(module == "/tmp/KDevelop-5.2.1-x86_64/usr/lib/libKF5Completion.so.5");
+
+- for (uint64_t expected : {0x7f48beedc00ul, 0x0ul, 0x36854ul, 0x236858ul, 0x2700ul}) {
++ for (auto expected : {0x7f48beedc00_u64, 0x0_u64, 0x36854_u64, 0x236858_u64, 0x2700_u64}) {
+ uint64_t addr = 0;
+ REQUIRE(reader >> addr);
+ REQUIRE(addr == expected);
diff --git a/community/heaptrack/76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch b/community/heaptrack/76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch
new file mode 100644
index 00000000..8448d679
--- /dev/null
+++ b/community/heaptrack/76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch
@@ -0,0 +1,16 @@
+diff --git a/src/util/linewriter.h b/src/util/linewriter.h
+index 73a7930..e895e87 100644
+--- a/src/util/linewriter.h
++++ b/src/util/linewriter.h
+@@ -158,6 +158,11 @@ public:
+ return __builtin_clzl(V);
+ }
+
++ inline static unsigned clz(long long unsigned V)
++ {
++ return __builtin_clzll(V);
++ }
++
+ template <typename V>
+ static char* writeHexNumber(char* buffer, V value)
+ {
diff --git a/community/heaptrack/PKGBUILD b/community/heaptrack/PKGBUILD
new file mode 100644
index 00000000..86e5c06b
--- /dev/null
+++ b/community/heaptrack/PKGBUILD
@@ -0,0 +1,15 @@
+# backport 32-bit specific fixed from trunk to 1.1.0
+
+source+=('76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch' '49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch' 'c456f6a1575fb2834238a1f693e7c7787d768d42.patch')
+sha256sums+=('7e5256b5f129d5b88c72b8621fc676322c4bcbb4388973d3b5c9b7ff2c874334' '2ef8e8b95792cbebfb33a1959e2fdb8fcbb24edd0243cccd0f25958d1592aaab' 'a8ad15176973a074e97492d7008555ecd895a8fbe7f0805a9f4562054311091d')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /}/ i \
+ cd ${pkgname}-${pkgver}\n \
+ patch -Np1 < ${srcdir}/76fd2e84ba133e96d2cfdf90cb715e66e923eb8f.patch\n \
+ patch -Np1 < ${srcdir}/49577e019ea791ee63962cdfe7e9c0c5b5c6ea4b.patch\n \
+ patch -Np1 < ${srcdir}/c456f6a1575fb2834238a1f693e7c7787d768d42.patch
+ '
+)"
diff --git a/community/heaptrack/c456f6a1575fb2834238a1f693e7c7787d768d42.patch b/community/heaptrack/c456f6a1575fb2834238a1f693e7c7787d768d42.patch
new file mode 100644
index 00000000..e6b8f739
--- /dev/null
+++ b/community/heaptrack/c456f6a1575fb2834238a1f693e7c7787d768d42.patch
@@ -0,0 +1,13 @@
+diff --git a/src/track/libheaptrack.cpp b/src/track/libheaptrack.cpp
+index 8646893..af1ba5e 100644
+--- a/src/track/libheaptrack.cpp
++++ b/src/track/libheaptrack.cpp
+@@ -121,7 +121,7 @@ inline void debugLog(const char fmt[], Args... args)
+ if (debugLevel <= s_debugVerbosity) {
+ RecursionGuard guard;
+ flockfile(stderr);
+- fprintf(stderr, "heaptrack debug(%d) [%d:%d]@%lu ", static_cast<int>(debugLevel), getpid(), gettid(),
++ fprintf(stderr, "heaptrack debug(%d) [%d:%d]@%" PRIu64 " ", static_cast<int>(debugLevel), getpid(), gettid(),
+ elapsedTime().count());
+ fprintf(stderr, fmt, args...);
+ fputc('\n', stderr);
diff --git a/community/python-faker/PKGBUILD b/community/python-faker/PKGBUILD
index 87168ec5..891d7841 100644
--- a/community/python-faker/PKGBUILD
+++ b/community/python-faker/PKGBUILD
@@ -1,15 +1,18 @@
# https://github.com/joke2k/faker/issues/408
# time-tests requiring 64 bit fail on i686 - obviously (year 2100 is not representable with 32 bits)
-source+=('remove-century-tests.patch')
-sha512sums+=('69d6c7685f49d28bc5a4ea952d6f0f6ab03e7c9956e338fc7e26d6a714de569641b82e95bb30de15b4598b6fbf3fb8e0a497fde2e28bd988fafbeb030bb24f91')
-
eval "$(
declare -f prepare | \
sed '
/^{\s*$/a \
- cd "$srcdir"/faker-$pkgver\
- patch -p1 -i "$srcdir/remove-century-tests.patch"\
- cd "$srcdir"
+ sed -i '"'"'/\\.date_\\(time_\\)\\?this_century(.*) >= /d'"'"' "$srcdir/faker-$pkgver/tests/providers/test_date_time.py" \
+ sed -i '"'"' \
+ $! N; \
+ /^\\(.\\+\\)\\n\\1$/ ! { \
+ P; \
+ D; \
+ } \
+ D; \
+ '"'"' "$srcdir/faker-$pkgver/tests/providers/test_date_time.py" \
'
)"
diff --git a/community/python-faker/remove-century-tests.patch b/community/python-faker/remove-century-tests.patch
deleted file mode 100644
index 57cddebf..00000000
--- a/community/python-faker/remove-century-tests.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- faker-0.8.4/tests/providers/test_date_time.py 2017-09-22 21:52:06.000000000 +0200
-+++ test_date_time.py 2017-09-25 11:14:26.013321696 +0200
-@@ -203,9 +203,6 @@
- return int(time.mktime(value.timetuple()))
-
- def test_date_time_this_period(self):
-- # test century
-- self.assertTrue(self._datetime_to_time(self.factory.date_time_this_century(after_now=False)) <= self._datetime_to_time(datetime.now()))
-- self.assertTrue(self._datetime_to_time(self.factory.date_time_this_century(before_now=False, after_now=True)) >= self._datetime_to_time(datetime.now()))
- # test decade
- self.assertTrue(self._datetime_to_time(self.factory.date_time_this_decade(after_now=False)) <= self._datetime_to_time(datetime.now()))
- self.assertTrue(self._datetime_to_time(self.factory.date_time_this_decade(before_now=False, after_now=True)) >= self._datetime_to_time(datetime.now()))
-@@ -231,17 +228,12 @@
- def test_date_time_this_period_with_tzinfo(self):
- # ensure all methods provide timezone aware datetimes
- with self.assertRaises(TypeError):
-- self.factory.date_time_this_century(before_now=False, after_now=True, tzinfo=utc) >= datetime.now()
-- with self.assertRaises(TypeError):
- self.factory.date_time_this_decade(after_now=False, tzinfo=utc) <= datetime.now()
- with self.assertRaises(TypeError):
- self.factory.date_time_this_year(after_now=False, tzinfo=utc) <= datetime.now()
- with self.assertRaises(TypeError):
- self.factory.date_time_this_month(after_now=False, tzinfo=utc) <= datetime.now()
-
-- # test century
-- self.assertTrue(self.factory.date_time_this_century(after_now=False, tzinfo=utc) <= datetime.now(utc))
-- self.assertTrue(self.factory.date_time_this_century(before_now=False, after_now=True, tzinfo=utc) >= datetime.now(utc))
- # test decade
- self.assertTrue(self.factory.date_time_this_decade(after_now=False, tzinfo=utc) <= datetime.now(utc))
- self.assertTrue(self.factory.date_time_this_decade(before_now=False, after_now=True, tzinfo=utc) >= datetime.now(utc))
-@@ -268,7 +260,6 @@
- def test_date_this_period(self):
- # test century
- self.assertTrue(self.factory.date_this_century(after_today=False) <= date.today())
-- self.assertTrue(self.factory.date_this_century(before_today=False, after_today=True) >= date.today())
- # test decade
- self.assertTrue(self.factory.date_this_decade(after_today=False) <= date.today())
- self.assertTrue(self.factory.date_this_decade(before_today=False, after_today=True) >= date.today())
diff --git a/community/vtk/PKGBUILD b/community/vtk/PKGBUILD
new file mode 100644
index 00000000..6c7a97bd
--- /dev/null
+++ b/community/vtk/PKGBUILD
@@ -0,0 +1,2 @@
+# temporary checksum fix for downloaded patch file
+sha512sums[3]='20a68b5b0821984fcd58638b12b00db875907f990a68147d7a7867431aaa6bfe1334deaefae4c64adce2dc845ae317167a5cf1d19ebed285d32b6e214e6d7068'
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 8531be1d..85773e57 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: 9a8d23e9abeb3de414fe2f2bb62a83193f59c390
+# upstream git revision: 2edc3f8d648d3f161a9593c0a41332dae246cdfd
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'bb700544d499a92dab141a218cc1eac62fdff0b67682748cb827035269c02a55' ]; then
- sha256sums[${i}]='35627a74558c1171af386dcb6d69c45619ec3189a4c6444d94b94f75f19da5c6'
+ if [ "${sha256sums[${i}]}" = '83d768f19193f6795b8159d81c6775b9f62f4994f2a0d8371ac243e7b0890db8' ]; then
+ sha256sums[${i}]='224d422c6eea90fa395e49adf672a48468fd9d702f698a3ab4c9b9ee40c7cd18'
fi
done
diff --git a/core/linux/config b/core/linux/config
index bc17d042..2b4c93f6 100644
--- a/core/linux/config
+++ b/core/linux/config
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.18.3-arch1 Kernel Configuration
+# Linux/x86 4.18.6-arch1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.0
+# Compiler: gcc (GCC) 8.2.1 20180831
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -43,7 +43,7 @@ CONFIG_ARCH_SUPPORTS_UPROBES=y
CONFIG_FIX_EARLYCON_MEM=y
CONFIG_PGTABLE_LEVELS=2
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=80200
+CONFIG_GCC_VERSION=80201
CONFIG_CLANG_VERSION=0
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_EXTABLE_SORT=y
@@ -302,6 +302,7 @@ CONFIG_HAVE_PERF_REGS=y
CONFIG_HAVE_PERF_USER_STACK_DUMP=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_RCU_TABLE_FREE=y
+CONFIG_HAVE_RCU_TABLE_INVALIDATE=y
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
CONFIG_HAVE_ALIGNED_STRUCT_PAGE=y
CONFIG_HAVE_CMPXCHG_LOCAL=y
@@ -7405,7 +7406,7 @@ CONFIG_RTC_DRV_RV3029_HWMON=y
#
# Platform RTC drivers
#
-CONFIG_RTC_DRV_CMOS=m
+CONFIG_RTC_DRV_CMOS=y
CONFIG_RTC_DRV_DS1286=m
CONFIG_RTC_DRV_DS1511=m
CONFIG_RTC_DRV_DS1553=m
diff --git a/core/nss/PKGBUILD b/core/nss/PKGBUILD
index afd28e8b..1a4dfa96 100644
--- a/core/nss/PKGBUILD
+++ b/core/nss/PKGBUILD
@@ -9,6 +9,3 @@ eval "$(
/cd nss-/a patch -Np2 -i ../no-plt.diff
'
)"
-
-# temporary, we have the wrong sum, is fixed upstream
-sha256sums[0]='2c643d3c08d6935f4d325f40743719b6990aa25a79ec2f8f712c99d086672f62'
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
new file mode 100644
index 00000000..8eba80f3
--- /dev/null
+++ b/extra/firefox/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export LDFLAGS+=" -Wl,--no-keep-memory"
+ '
+)"
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index a4ad284f..27d89ae1 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,9 +4,9 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-pkgver=4.18.5
+pkgver='4.18.6'
_srcname=linux-${pkgver}
-pkgrel=1
+pkgrel='1'
arch=('i686')
url="https://www.kernel.org/"
license=('GPL2')
@@ -24,9 +24,9 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('fb090a3680eddf6f10bf895bc3075bd3f830e3d2429ce469982db5a28df647bd'
+sha256sums=('05db97fd6891217af6d4203bdc442ef2af78d7902b6a8e9bd348682704c22894'
'SKIP'
- '3957b6865cff44be43d879db8131974c7a4933ae0a2462f491640a11964abd7c'
+ 'af0060a53e75f3c6ca348a5ef8317a5908bb9d1d7ab2434ca9142d91309a0290'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index 621b184f..4fbfec7e 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.18.5-1 Kernel Configuration
+# Linux/x86 4.18.6-1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.0
+# Compiler: gcc (GCC) 8.2.1 20180831
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -43,7 +43,7 @@ CONFIG_ARCH_SUPPORTS_UPROBES=y
CONFIG_FIX_EARLYCON_MEM=y
CONFIG_PGTABLE_LEVELS=3
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=80200
+CONFIG_GCC_VERSION=80201
CONFIG_CLANG_VERSION=0
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_EXTABLE_SORT=y
@@ -302,6 +302,7 @@ CONFIG_HAVE_PERF_REGS=y
CONFIG_HAVE_PERF_USER_STACK_DUMP=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_RCU_TABLE_FREE=y
+CONFIG_HAVE_RCU_TABLE_INVALIDATE=y
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
CONFIG_HAVE_ALIGNED_STRUCT_PAGE=y
CONFIG_HAVE_CMPXCHG_LOCAL=y
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 93b03bf7..933ce385 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: cfe9d37d927bb78eb0f2992ef8f14df121138e60
+# upstream git revision: 2edc3f8d648d3f161a9593c0a41332dae246cdfd
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '931789c60228540e2f727eee1bf59583446f2a5fc5a2495ca946e2bfc1b89099' ]; then
- sha256sums[${i}]='010b73eb4ede60d16bc5f1471fa076f9d5639fa15d62073bf4ed075064b9c4a4'
+ if [ "${sha256sums[${i}]}" = 'fd5a7203579777ab2c0deb3bcdf94ded8a4422fefc81506b98c3bce8070b5a8f' ]; then
+ sha256sums[${i}]='ad2a55218708ad7af672c718013b9626b847719371bb1a38dfd7df374e87624a'
fi
done
@@ -13,4 +13,3 @@ eval "$(
\,/tools/objtool" ,d
'
)"
-010b73eb4ede60d16bc5f1471fa076f9d5639fa15d62073bf4ed075064b9c4a4 ../work/tmp.zXfUnz/config
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index fd3bb957..b68c8746 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.18.3-zen1 Kernel Configuration
+# Linux/x86 4.18.6-zen1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.0
+# Compiler: gcc (GCC) 8.2.1 20180831
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -43,7 +43,7 @@ CONFIG_ARCH_SUPPORTS_UPROBES=y
CONFIG_FIX_EARLYCON_MEM=y
CONFIG_PGTABLE_LEVELS=2
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=80200
+CONFIG_GCC_VERSION=80201
CONFIG_CLANG_VERSION=0
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_EXTABLE_SORT=y
@@ -53,7 +53,7 @@ CONFIG_THREAD_INFO_IN_TASK=y
# General setup
#
CONFIG_ZEN_INTERACTIVE=y
-# CONFIG_SCHED_PDS is not set
+# CONFIG_SCHED_MUQSS is not set
CONFIG_INIT_ENV_ARG_LIMIT=32
# CONFIG_COMPILE_TEST is not set
CONFIG_LOCALVERSION="-zen"
@@ -306,6 +306,7 @@ CONFIG_HAVE_PERF_REGS=y
CONFIG_HAVE_PERF_USER_STACK_DUMP=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_RCU_TABLE_FREE=y
+CONFIG_HAVE_RCU_TABLE_INVALIDATE=y
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
CONFIG_HAVE_ALIGNED_STRUCT_PAGE=y
CONFIG_HAVE_CMPXCHG_LOCAL=y
@@ -540,6 +541,8 @@ CONFIG_NR_CPUS=8
CONFIG_SCHED_SMT=y
CONFIG_SCHED_MC=y
CONFIG_SCHED_MC_PRIO=y
+CONFIG_RQ_NONE=y
+CONFIG_SHARERQ=0
# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
CONFIG_PREEMPT=y
@@ -7437,7 +7440,7 @@ CONFIG_RTC_DRV_RV3029_HWMON=y
#
# Platform RTC drivers
#
-CONFIG_RTC_DRV_CMOS=m
+CONFIG_RTC_DRV_CMOS=y
CONFIG_RTC_DRV_DS1286=m
CONFIG_RTC_DRV_DS1511=m
CONFIG_RTC_DRV_DS1553=m
diff --git a/extra/thunderbird/PKGBUILD b/extra/thunderbird/PKGBUILD
new file mode 100644
index 00000000..8eba80f3
--- /dev/null
+++ b/extra/thunderbird/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export LDFLAGS+=" -Wl,--no-keep-memory"
+ '
+)"
diff --git a/extra/vulkan-lunarg-tools/PKGBUILD b/extra/vulkan-lunarg-tools/PKGBUILD
new file mode 100644
index 00000000..8a87fa09
--- /dev/null
+++ b/extra/vulkan-lunarg-tools/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f package_vulkan-trace | \
+ sed '
+ /_install / s/libVkLayer_vktrace_layer/\032/
+ '
+)"