Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:02:30 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:02:30 +0100
commit54d673f3676d18dc1310d17d4f6cdadd2418d7c8 (patch)
treeeef0f003adbabfeb0df0cb72b2315a5ff4a6c786
parent165b5d95035046775ea689f67af7d1f973820677 (diff)
parentd3703bea4f193f2e340fe9eb55a6d6d54c9c00b0 (diff)
Merge branch 'master' into i486
-rw-r--r--extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch27
-rw-r--r--extra/nasm/PKGBUILD25
2 files changed, 36 insertions, 16 deletions
diff --git a/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch b/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch
new file mode 100644
index 00000000..87ec601c
--- /dev/null
+++ b/extra/nasm/0001-Remove-invalid-pure_func-qualifiers.patch
@@ -0,0 +1,27 @@
+From d0dabb46a821b2506681f882af0d5696d2c2bade Mon Sep 17 00:00:00 2001
+From: Michael Simacek <msimacek@redhat.com>
+Date: Thu, 8 Feb 2018 14:47:08 +0100
+Subject: [PATCH] Remove invalid pure_func qualifiers
+
+---
+ include/nasmlib.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/nasmlib.h b/include/nasmlib.h
+index 79e866b..c93cef0 100644
+--- a/include/nasmlib.h
++++ b/include/nasmlib.h
+@@ -191,8 +191,8 @@ int64_t readstrnum(char *str, int length, bool *warn);
+ * seg_init: Initialise the segment-number allocator.
+ * seg_alloc: allocate a hitherto unused segment number.
+ */
+-void pure_func seg_init(void);
+-int32_t pure_func seg_alloc(void);
++void seg_init(void);
++int32_t seg_alloc(void);
+
+ /*
+ * many output formats will be able to make use of this: a standard
+--
+2.14.3
+
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
index f644e426..220091bd 100644
--- a/extra/nasm/PKGBUILD
+++ b/extra/nasm/PKGBUILD
@@ -1,20 +1,13 @@
+# see FS#60380
+source+=('0001-Remove-invalid-pure_func-qualifiers.patch')
+sha1sums+=('b853817a1dd5dc902b36ae80d11402d68e6d9a44')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/0001-Remove-invalid-pure_func-qualifiers.patch"
+}
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- # remove all fonts and ghostscript (we don't build the manual)
- makedepends=(${makedepends[@]//perl-font-ttf/})
- makedepends=(${makedepends[@]//perl-sort-versions/})
- makedepends=(${makedepends[@]//fontconfig/})
- makedepends=(${makedepends[@]//adobe-source-sans-pro-fonts/})
+ # remove ttf-liberation (X packages missing for installing the font)
makedepends=(${makedepends[@]//ttf-liberation/})
- makedepends=(${makedepends[@]//ghostscript/})
-
- eval "$(
- declare -f build | \
- sed '
- /make .*doc/d
- '
- )"
fi
-
-# orginal download link unstable
-#sed -i 's@http://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz@https://ftp.osuosl.org/pub/blfs/conglomeration/${pkgname}/${pkgname}-${pkgver}.tar.xz@' PKGBUILD