Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:07:56 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:07:56 +0100
commit1897f7c02af5ed11fa4c47c1a8de9f214dbdbd8c (patch)
tree8084d70e20c2369e155cab74664f4a4d748095ed
parent92cd2809080c7de30b25ebab109bb22bc6dc1bc2 (diff)
parent10a10ced5a32341c74809f9353cbafcc90c01eac (diff)
Merge branch 'master' into i486
-rw-r--r--core/gpm/PKGBUILD7
-rw-r--r--core/gpm/gpm-1.20.7-glibc-2.26-1.patch58
-rw-r--r--extra/libgit2/PKGBUILD2
-rw-r--r--extra/x265/PKGBUILD2
4 files changed, 2 insertions, 67 deletions
diff --git a/core/gpm/PKGBUILD b/core/gpm/PKGBUILD
deleted file mode 100644
index 242ad34e..00000000
--- a/core/gpm/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-source+=('gpm-1.20.7-glibc-2.26-1.patch')
-sha256sums+=('fc916df0f7060083ae48d8fe9949e68552f219cb11ee9f5b245a599a5b0cc6a8')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/gpm-1.20.7-glibc-2.26-1.patch"
-}
diff --git a/core/gpm/gpm-1.20.7-glibc-2.26-1.patch b/core/gpm/gpm-1.20.7-glibc-2.26-1.patch
deleted file mode 100644
index 6f63c273..00000000
--- a/core/gpm/gpm-1.20.7-glibc-2.26-1.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -Naur gpm-1.20.7-orig/src/daemon/open_console.c gpm-1.20.7/src/daemon/open_console.c
---- gpm-1.20.7-orig/src/daemon/open_console.c 2012-10-26 21:21:38.000000000 +0000
-+++ gpm-1.20.7/src/daemon/open_console.c 2017-08-08 17:58:15.176232558 +0000
-@@ -23,6 +23,10 @@
- #include <sys/stat.h> /* stat() */
- #include <sys/ioctl.h> /* ioctl */
-
-+#ifdef HAVE_SYS_SYSMACROS_H
-+#include <sys/sysmacros.h> /* major() w/newer glibc */
-+#endif
-+
- /* Linux specific (to be outsourced in gpm2 */
- #include <linux/serial.h> /* for serial console check */
- #include <asm/ioctls.h> /* for serial console check */
-diff -Naur gpm-1.20.7-orig/src/prog/gpm-root.y gpm-1.20.7/src/prog/gpm-root.y
---- gpm-1.20.7-orig/src/prog/gpm-root.y 2012-10-26 21:21:38.000000000 +0000
-+++ gpm-1.20.7/src/prog/gpm-root.y 2017-08-08 18:00:36.442898559 +0000
-@@ -443,6 +443,7 @@
- }
-
- /*---------------------------------------------------------------------*/
-+#if 0
- static int f_debug_one(FILE *f, Draw *draw)
- {
- DrawItem *ip;
-@@ -465,6 +466,7 @@
- #undef LINE
- return 0;
- }
-+#endif
-
- int f_debug(int mode, DrawItem *self, int uid)
- {
-@@ -960,10 +962,8 @@
- /*------------*/
- static inline void scr_restore(int fd, FILE *f, unsigned char *buffer, int vc)
- {
-- int x,y, dumpfd;
-+ int dumpfd;
- char dumpname[20];
--
-- x=buffer[2]; y=buffer[3];
-
- /* WILL NOT WORK WITH DEVFS! FIXME! */
- sprintf(dumpname,"/dev/vcsa%i",vc);
-@@ -1196,11 +1196,7 @@
- LOG_DAEMON : LOG_USER);
- /* reap your zombies */
- childaction.sa_handler=reap_children;
--#if defined(__GLIBC__)
-- __sigemptyset(&childaction.sa_mask);
--#else /* __GLIBC__ */
-- childaction.sa_mask=0;
--#endif /* __GLIBC__ */
-+ sigemptyset(&childaction.sa_mask);
- childaction.sa_flags=SA_INTERRUPT; /* need to break the select() call */
- sigaction(SIGCHLD,&childaction,NULL);
-
diff --git a/extra/libgit2/PKGBUILD b/extra/libgit2/PKGBUILD
index 052719d7..e0b17681 100644
--- a/extra/libgit2/PKGBUILD
+++ b/extra/libgit2/PKGBUILD
@@ -1,7 +1,7 @@
# See: https://github.com/libgit2/libgit2/pull/4631
source+=('libgit2-ssp-offset64-stat-buf.patch')
-sha1sums+=('378a2c3eaef1957145aa58f51f75a07c634f77d7')
+sha256sums+=('4eceeb944c7ea2dd2f879a279d5eb0f80ae32675410a6601bcc07ccd0189e8cf')
prepare() {
cd $pkgname-$pkgver
diff --git a/extra/x265/PKGBUILD b/extra/x265/PKGBUILD
index 0dc3dc58..5e6e000e 100644
--- a/extra/x265/PKGBUILD
+++ b/extra/x265/PKGBUILD
@@ -8,7 +8,7 @@ eval "$(
)"
# thanks, debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910963
source+=('0003-detect512-is-needed-on-all-architectures.patch')
-sha256sum+=('+6baa25d11c81ad4ee49e9f2a367db4c770eb8cccf81f7bdaadb942621288a271')
+sha256sums+=('+6baa25d11c81ad4ee49e9f2a367db4c770eb8cccf81f7bdaadb942621288a271')
eval "$(
declare -f prepare | \
sed '