Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 2 insertions, 27 deletions
diff --git a/setup.py b/setup.py
index 02029a70..a4f49f92 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,2 @@
-import setuptools, glob, shutil
-
-with open("README.md", "r") as fh:
- long_description = fh.read()
-
-with open('VERSION', 'r') as fh:
- VERSION = fh.read()
-
-setuptools.setup(
- name="archinstall",
- version=VERSION,
- author="Anton Hvornum",
- author_email="anton@hvornum.se",
- description="Arch Linux installer - guided, templates etc.",
- long_description=long_description,
- long_description_content_type="text/markdown",
- url="https://github.com/Torxed/archinstall",
- packages=setuptools.find_packages(),
- classifiers=[
- "Programming Language :: Python :: 3.8",
- "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
- "Operating System :: POSIX :: Linux",
- ],
- python_requires='>=3.8',
- setup_requires=['wheel'],
- package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py') + glob.glob('profiles/applications/*.py')},
-)
+import setuptools
+setuptools.setup()