Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f67f1eca..83c68e1d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,12 +11,10 @@ authors = [
]
license = {text = "GPL-3.0-only"}
readme = "README.md"
-requires-python = ">=3.10"
+requires-python = ">=3.11"
keywords = ["linux", "arch", "archinstall", "installer"]
classifiers = [
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Operating System :: POSIX :: Linux",
]
dependencies = [
@@ -60,7 +58,7 @@ packages = ["archinstall"]
# where = ["archinstall"]
[tool.mypy]
-python_version = "3.10"
+python_version = "3.11"
files = "archinstall/"
exclude = "tests"
#check_untyped_defs=true