Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml44
1 files changed, 29 insertions, 15 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6e0fcb99..a1208bfc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,23 +4,23 @@ build-backend = "setuptools.build_meta"
[project]
name = "archinstall"
-dynamic = ["version", "entry-points"]
+dynamic = ["version"]
description = "Arch Linux installer - guided, templates etc."
authors = [
{name = "Anton Hvornum", email = "anton@hvornum.se"},
]
license = {text = "GPL-3.0-only"}
readme = "README.md"
-requires-python = ">=3.10"
-
+requires-python = ">=3.11"
keywords = ["linux", "arch", "archinstall", "installer"]
-
classifiers = [
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Operating System :: POSIX :: Linux",
]
+dependencies = [
+ "simple-term-menu==1.6.4",
+ "pyparted @ https://github.com//dcantrell/pyparted/archive/v3.13.0.tar.gz#sha512=26819e28d73420937874f52fda03eb50ab1b136574ea9867a69d46ae4976d38c4f26a2697fa70597eed90dd78a5ea209bafcc3227a17a7a5d63cff6d107c2b11",
+]
[project.urls]
Home = "https://archlinux.org"
@@ -28,27 +28,41 @@ Documentation = "https://archinstall.readthedocs.io/"
Source = "https://github.com/archlinux/archinstall"
[project.optional-dependencies]
+log = ["systemd_python==235"]
+dev = [
+ "mypy==1.10.0",
+ "pre-commit==3.7.0",
+]
doc = ["sphinx"]
[project.scripts]
archinstall = "archinstall:run_as_a_module"
+[tool.setuptools.dynamic]
+version = {attr = "archinstall.__version__"}
+readme = {file = ["README.rst", "USAGE.rst"]}
+
[tool.setuptools]
-packages = ["archinstall", "profiles", "examples"]
+packages = ["archinstall"]
[tool.setuptools.package-data]
-archinstall = [
- "examples/*.py",
- "profiles/*.py",
- "profiles/applications/*.py"
+# We could specify locales/lancuages.json etc instead, but catchall works too.
+"archinstall" = [
+ "**/*.py",
+ "**/*.mo",
+ "**/*.po",
+ "**/*.pot",
+ "**/*.json",
]
-[tool.setuptools.dynamic]
-version = {attr = "archinstall.__version__"}
+# [tool.setuptools.packages.find]
+# where = ["archinstall"]
[tool.mypy]
-python_version = "3.10"
+python_version = "3.11"
+files = "archinstall/"
exclude = "tests"
+check_untyped_defs=true
[tool.bandit]
targets = ["archinstall"]