Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD/python-archinstall
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD/python-archinstall')
-rw-r--r--PKGBUILD/python-archinstall/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD/python-archinstall/PKGBUILD b/PKGBUILD/python-archinstall/PKGBUILD
new file mode 100644
index 00000000..276f6acf
--- /dev/null
+++ b/PKGBUILD/python-archinstall/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Anton Hvornum anton@hvornum.se
+# Contributor: Anton Hvornum anton@hvornum.se
+pkgname="archinstall"
+pkgver="2.0.4rc4"
+pkgdesc="Installs ${pkgname} as a python library."
+pkgrel=1
+url="https://github.com/Torxed/archinstall"
+license=('GPLv3')
+provides=("${pkgname}")
+md5sums=('SKIP')
+arch=('x86_64')
+source=("${pkgname}-v${pkgver}-x86_64.tar.gz::https://github.com/Torxed/archinstall/archive/v$pkgver.tar.gz")
+depends=('python>=3.8')
+#optdepends=('python-pip: Adds pip version handling and management.')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ python3 setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}