Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Hvornum <anton.feeds+github@gmail.com>2020-07-08 13:22:05 +0000
committerAnton Hvornum <anton.feeds+github@gmail.com>2020-07-08 13:22:05 +0000
commitfc4790b33c98ca14469e88c00544701a85365d3a (patch)
tree7111ee681dbaa6e0ddee73dfc941bc1855dfa241 /setup.py
parent4f18ac473abef763d6ea2846348da21693d878bd (diff)
Added symlinks instead of copying when building. Also mofied the __file__ path in __main__.py as it was pointing a bit off for some reason
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 3 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index ddd35cdf..48b928bf 100644
--- a/setup.py
+++ b/setup.py
@@ -3,11 +3,9 @@ import setuptools, glob, shutil
with open("README.md", "r") as fh:
long_description = fh.read()
-#shutil.copytree('examples', 'archinstall/examples')
-
setuptools.setup(
name="archinstall",
- version="2.0.3rc5",
+ version="2.0.3rc6",
author="Anton Hvornum",
author_email="anton@hvornum.se",
description="Arch Linux installer - guided, templates etc.",
@@ -21,7 +19,5 @@ setuptools.setup(
"Operating System :: POSIX :: Linux",
],
python_requires='>=3.8',
- package_data={'archinstall': glob.glob('examples/*.py')},
-)
-
-#shutil.rmtree('archinstall/examples') \ No newline at end of file
+ package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py')},
+) \ No newline at end of file