Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Hvornum <anton.feeds+github@gmail.com>2020-07-06 18:44:42 +0200
committerAnton Hvornum <anton.feeds+github@gmail.com>2020-07-06 18:44:42 +0200
commitb4a6f03b962d9309a1a18bd6de6a50a0146252a1 (patch)
treebcdc2041ab9fe8733760fbe5d1d9f344923ceb0a /setup.py
parentff9475ffe49d4ff8bca2b7fc1b6f8105e5277745 (diff)
Converted the lib to a pip supported structure to make packaging easier. Also tweaked some minor issues and added the AUR function
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..9571d41d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+import setuptools
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+setuptools.setup(
+ name="archinstall-Torxed", # Replace with your own username
+ version="2.0.0",
+ author="Anton Hvornum",
+ author_email="anton@hvornum.se",
+ description="Arch Linux installer - guided, templates etc.",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://github.com/Torxed/archinstall",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: GPL 3.0 License",
+ "Operating System :: Arch Linux",
+ ],
+ python_requires='>=3.8',
+) \ No newline at end of file