Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAnton Hvornum <anton.feeds@gmail.com>2021-04-21 13:10:56 +0200
committerAnton Hvornum <anton.feeds@gmail.com>2021-04-21 13:10:56 +0200
commitccb75f70b9468cb9e8485bb6a0692026ea1862a7 (patch)
treea96058275c0974f3f2d9ae438a90ff5d64864735 /pyproject.toml
parent8b9f16a0284c5261a29b9818809cbe45a9c0c10b (diff)
parent752d7b7a8d28dff0c40d7fada823d94c92fcd195 (diff)
Merged in latest changes and history from torxed-2.2.0 to avoid odd history in PR #315
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 29 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9787c3bd..da6f860e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,30 @@
[build-system]
-requires = ["setuptools", "wheel"]
-build-backend = "setuptools.build_meta"
+requires = ["flit_core >=2,<4"]
+build-backend = "flit_core.buildapi"
+
+[tool.flit.metadata]
+module = "archinstall"
+author = "Anton Hvornum"
+author-email = "anton@hvornum.se"
+home-page = "https://archlinux.org"
+classifiers = [ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+"Programming Language :: Python :: 3.8",
+"Programming Language :: Python :: 3.9",
+"License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+"Operating System :: POSIX :: Linux",
+]
+description-file = "README.md"
+requires-python=">=3.8"
+[tool.flit.metadata.urls]
+Source = "https://github.com/archlinux/archinstall"
+Documentation = "https://archinstall.readthedocs.io/"
+
+[tool.flit.scripts]
+archinstall = "archinstall:run_as_a_module"
+
+[tool.flit.sdist]
+include = ["docs/"]
+exclude = ["docs/*.html", "docs/_static","docs/*.png","docs/*.psd"]
+
+[tool.flit.metadata.requires-extra]
+doc = ["sphinx"] \ No newline at end of file