Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Hvornum <anton@hvornum.se>2022-04-29 11:26:34 +0200
committerAnton Hvornum <anton@hvornum.se>2022-04-29 11:26:34 +0200
commit7fc65fad0c7c2f6d4095d9ccf7b7463e6401fd21 (patch)
tree6e34a00f3c229bd5eb73a1816bf5d4ce3495f821 /PKGBUILD
parent58a734e90e0497b0c557266142650a90f48ddc53 (diff)
Updated PKGBUILD to handle symlink issues for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 37 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f0fd384..f368c417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,47 @@
-# Maintainer: Anton Hvornum <anton@hvornum.se>
-# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Maintainer: David Runge <dvzrv@archlinux.org>
+# Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Anton Hvornum <anton@hvornum.se>
# Contributor: demostanis worlds <demostanis@protonmail.com>
-pkgname=archinstall-git
-pkgver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+pkgname=archinstall
+pkgver=2.4.2
+#pkgver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
pkgrel=1
pkgdesc="Just another guided/automated Arch Linux installer with a twist"
-arch=('any')
+arch=(any)
url="https://github.com/archlinux/archinstall"
-license=('GPL')
-depends=('python')
-makedepends=('python-setuptools' 'python-sphinx')
-provides=('python-archinstall')
-conflicts=('archinstall' 'python-archinstall' 'python-archinstall-git')
+license=(GPL3)
+depends=(python)
+makedepends=(python-build python-installer python-flit python-setuptools python-sphinx python-wheel)
+provides=(python-archinstall)
+conflicts=(python-archinstall)
+replaces=(python-archinstall)
+source=(
+ $pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz
+ $pkgname-$pkgver.tar.gz.sig::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig
+)
+sha512sums=('9516719c4e4fe0423224a35b4846cf5c8daeb931cff6fed588957840edc5774e9c6fe18619d2356a6d76681ae3216ba19f5d0f0bd89c6301b4ff9b128d037d13'
+ 'SKIP')
+b2sums=('a29ae767756f74ce296d53e31bb8376cfa7db19a53b8c3997b2d8747a60842ba88e8b18c505bc56a36d685f73f7a6d9e53adff17953c8a4ebaabc67c6db8e583'
+ 'SKIP')
+validpgpkeys=('256F73CEEFC6705C6BBAB20E5FBBB32941E3740A') # Anton Hvornum (Torxed) <anton@hvornum.se>
+
+prepare() {
+ cd $pkgname-$pkgver
+ # use real directories for examples and profiles, as symlinks do not work
+ # with flit or setuptools PEP517 backends
+ rm -fv $pkgname/{examples,profiles}
+ mv -v examples profiles $pkgname/
+}
build() {
- cd "$startdir"
- python setup.py build
- PYTHONDONTWRITEBYTECODE=1 make man -C docs
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
+ PYTHONDONTWRITEBYTECODE=1 make man -C docs
}
package() {
- cd "$startdir"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
-}
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 docs/_build/man/archinstall.1 -t "$pkgdir/usr/share/man/man1/"
+} \ No newline at end of file